Publicité

Si comme moi vous avez encore un site chez free.fr, vous devez certainement en avoir marre de plus pouvoir mettre à jour votre Wordpress, Joomla, drupal préféré pour cause de version de php obsolète.
Pourtant dans votre .htacess vous avez bien mis une seule ligne php 1 (ou php 5) pour passer de la version 4.4.3 à la 5.x.x.
Une fois par semaine (voir plus) votre google préféré vous dit que votre version de wordpress est obsolète

Cher propriétaire ou webmaster du site http://j.baptiste.free.fr/, La dernière exploration de votre site nous a permis de constater que vous utilisiezWordPress x.x.x. Nous vous recommandons d'installer la dernière version de ce logiciel. Les versions plus anciennes ou dépourvues de correctifs sont plus vulnérables aux attaques de hackers et aux logiciels malveillants susceptibles de gêner vos utilisateurs. Pour télécharger la dernière version, accédez à la page de téléchargement de WordPress. Si vous avez déjà installé la dernière version de WordPress, vous pouvez ignorer ce message. Si vous avez d'autres questions concernant la réception de ce message, vous pouvez consulter le message de blog publié par Google qui contient davantage d'informations à ce sujet. Cordialement, L'équipe Google chargée de la qualité des recherches

Free ne doit pas vouloir changer sûrement parce qu'il y a quelques sites obsolètes qui ne toléreront pas le php 5.3. Sûrement des sites à grande audience. En attendant c'est le statu-quo pour les autres ...

Mais les choses change enfin évoluer, enfin d’après le newgroup car dans les fais le serveurs sur lequel je suis est encore en PHP Version 5.1.3RC4-dev


voici ce que l’on trouve sur le newsgroup de free page perso par roro35

Bonjour,

Il semble que certains sites (serveurs) soient déjà passés en php 5.3.9
et visiblement ce n'est pas un fake

Si cela est confirmé, c''est une très bonne nouvelle

Pour ma part la conf de mon site n'a pas changé.
Par contre, certains rencontres des erreurs 500 -> fichier .htacces

Serait il possible d'avoir des infos supplémentaires afin de pouvoir les relayer (même si elles sont non officielles) ?

Notamment :
- la directive "php 1" du fichier .htaccess risque t'elle de poser problème ?
- si oui, serait ce également le cas si elle est encadrée par un <ifDefine Free> ?
- peut t-on compter sur de nouvelles extensions php (ex : "pdo-mysql") ?
- certaines restrictions (proxy sortant ?) vont elles être assouplies de sorte que l'accès http puisse se faire sur des sites de confiance (ex : wordpress.org ;))
- au niveau mémoire, la limite se situe toujours à 32 Mo ?
- quid des nouvelles directives apache autorisées via le fichier .htaccess (ex : rewrite rules, gestion du cache)
- ...

Un grand merci à ceux (celui ?) qui gèrent les pages perso ainsi qu'aux bonnes volontés qui animent ces newsgroups.

Cordialement.

Bon y a plus qu’à attendre ...


Vous avez aimé cet article ? Alors partagez-le avec vos amis en cliquant sur les boutons ci-dessous :


Commentaires (2)

  • Invité - farvardin

    <p>Alors, ça en est où ? On est condamné à garder un php obsolète, donc des CMS obsolètes, donc des CMS avec des failles de sécurité ? Ou bien Free va passer à php 5.3 ou 5.4 prochainement ?</p>

  • Invité - Baptiste Jerome

    Invité - farvardin

    <p>Pour ma part s'en est toujours à <br>PHP Version 5.1.3RC4-dev<br>Il faut que je regarde si free n'a pas envoyé une note de service pour paramétrer un truc</p>

Poster un commentaire en tant qu'invité

0